Resolved
Systems have returned to a healthy state and requests should now be solved as normal. The incident is now resolved.
Monitoring
We have identified upstream issues with one of our RPC providers that is causing a partial outage in our indexing systems and delay in solving new deposit and withdrawal requests. The team is continuing to monitor the issue and the upstream provider is addressing the outage as a P0 issue. Funds are not at risk.